Samet AKIN

Samet AKIN

ALAYLI YAZILIMCI

Composer’ın eski php versiyonunu kullanma sorunsalı

Windows üzerinde composer kullanan kullanıcıların composer ile proje indirmeye çalışırken düşük php versiyonunu görmesi oldukça can sıkıcı.  Sorun php versiyonunu yükselttiğinde VEYA aynı anda birden fazla php versiyonu kullanırken, composer ile bir projeyi indirmeye çalışırken çıkagelen bu sorundur ve basit bir şekilde çözülebiliyor.

Cmd üzerinde php -v   komutunu verdiğinizde composerin hangi versiyonu baz aldığını görebilirsiniz.

1 – Bilgisayarım’a sağ tıklayın

2- Gelişmiş Sistem Ayarları

3- Gelişmiş

4- Ortam Değişkenleri

5 – PATH Değişkenin soruna hangi php versiyonunu göstermek istiyorsanız onun yolunu gösterin.

Hemen Örnek vereyim; Siz ilk olarak değişkeni düzenlerken karşınıza

C:\Users\Samet\AppData\Roaming\Composer\vendor\bin\

gibi bir yol çıkar. Bu yolun sonuna php.exe dosyanız hangi klasordeyse onun yolunu yazmalarınız. Ben easyphp kullanıyorum ve ben kendi php versiyonunu yolunu yazıyorum.

D:\Easy7\eds-binaries\php\php704vc14x86x170227162811

Buda benim php.exe dosyamın bulunduğu klasör.

Şimdi sizin nasıl yapmanız gerektiğini söyleyeceğim. Burada dikkat etmeni gereken bir husus mevcut.

PATH_yolu;(Noktalı virgülü unutmayın)Php_klasor_yolu

C:\Users\Samet\AppData\Roaming\Composer\vendor\bin\;D:\Easy7\eds-binaries\php\php704vc14x86x170227162811

Aradaki noktalı virgülü unutmayın. Ayrıca benim yolumun aynısını kopyalarsanız çalışmaz böyle bir hataya düşmeyin.

Şimdi yeni php versiyonunuzu görmek için, daha önce açtığınız cmdleri kapatın ve yeni bir cmd açın. ve komut satırına php -v  yazın yeni versiyonunuz hayırlısı olsun

 

Not : cmd açmak için ; Başlat -> Çalıştır -> cmd 

 

 

 

 

DROP A COMMENT

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir